28
- juni
2017
Posted By : Alf Otto Fagermo
Ikke oppgrader WordPress enda!

8. juni ble WordPress 4.8 «Evans» lansert. Denne bør du ikke oppgradere til med mindre du absolutt må.

Det er ikke ofte et selskap som meg ber deg vente med en oppdatering av WordPress, men det er en helt spesiell grunn til det. Har du et tema som bruker HTML i tekstwidgetene, så bør du faktisk vente til tidligst 4.8.1.

En av de nye tingene som ble lansert i 4.8 var at tekstwidgeten nå støtter det samme som vanlige innlegg og sider. De har nemlig aktivert TinyMCE. Problemet er at denne er aktivert som standard og gjør slik at den HTML-koden du hadde fra før, blir overskrevet og til tider fjernet.

Vår første erfaring med dette var på en av sidene som bruker temaet Original fra PressLayer, der du har fire tekstwidgeter i bunnen som ser veldig bra ut, men som gjør det på grunn av HTML-koder som inneholder egne <div>-tagger.

Har du muligheten til å heller oppdatere til 4.7.5, så er det vår beste anbefaling inntil buggen med de nye tekstwidgetene er fikset. Oppdaterer du til 4.8 eller kanskje du har gjort det allerede, gjør følgende:

  • Gå på Vis kilde på din nåværende side
  • Kopier HTML-koden til alle dine nåværende widgeter som har en spesiell kode til f.eks. Notisblokk i Windows
  • Gjør de endringene du må gjøre
  • Gå inn på Utseende -> Widgeter og endre til Tekst på de widgetene du skal oppdatere
  • Lim inn HTML-koden du endret på i Notisblokk
  • Trykk Lagre

Her kan du lese mer om buggen.

Skulle uhellet være ute og skaden allerede skjedd, ta kontakt med oss, så skal vi prøve å hjelpe deg med å få koden din tilbake.

Kommentarer

kommentarer