02
- desember
2015
Posted By : Alf Otto Fagermo
Hold koden din oppdatert

Sliter du med gammel kode? Nå kan det være nødvendig å dobbeltsjekke at koden din fortsatt vil fungere med nyere utgaver av PHP.

En av våre kunder kom med en påminnelse fra webhotelleverandøren om at de kommer til å utfase PHP versjon 5.3 til fordel for 5.5.

Det er over to år siden 5.5 ble sluppet og nyeste versjon nå er 5.6.16. En ganske viktig forskjell fra 5.3 og 5.5 er bruken av forkortede tagger. En (u)vane blant webutviklere som har holdt på i noen år, er å bruke <? for å markere starten på en PHP-tagg. Denne vil da ikke fungere på versjoner etter 5.3. Undertegnede måtte i dag se igjennom koden til alle sider som var hostet hos den aktuelle webhotelleverandøren at ingen viktige filer ville slutte å fungere etter at oppgraderingen var fullført.

For har du flere filer som består av <? istedet for <?php, vil du oppleve at koden blir skrevet i ren tekst fremfor at scriptet blir kjørt.

Dette er kanskje gammelt nytt, men likevel en grei påminnelse.

Og hvis du lurte, denne serveren kjører PHP 5.5.29.