05
- mai
2017
Posted By : Alf Otto Fagermo
Fiffig utvidelse

Har du noen gang lurt på hvilken PHP-versjon serveren din kjører og hvor mye kontrollpanelet i WordPress faktisk bruker?

Server IP & Memory Usage Display er en av mange utvidelser som kan gi deg svaret på dette. Selvfølgelig er det mulig å laste opp en tradisjonell phpinfo for å sjekke versjonen til PHP og MySQL. Men for nerdene av oss som er opptatt av teknisk informasjon, kan det faktisk være et nyttig verktøy å få denne informasjonen opp i kontrollpanelet til WordPress.

En sjekk Fairmedia har gjort på de ulike sidene som vi har kontroll over, viser en stor forskjell på hvilke versjoner som kjøres på de ulike webhotellene. For menigmann har det kanskje ikke så mye å si, men kort fortalt så kan du si at PHP-versjonen kan nesten tilsvare hvilken versjon av Windows du kjører. Det beste er selvfølgelig å kjøre nyeste versjon. Men det kan være mange grunner til å holde igjen versjonen som kjøres på serveren av kompatabilitetsgrunner.

For store webhotell er det et spørsmål om prioritering og hensyn til kunder. Selve operasjonen med å oppgradere trenger ikke å ta så veldig lang tid, men det handler helt og holdent om å veie opp sikkerhetsrisikoen mot ytelse og hensyn til kundenes versjon av publiseringsløsning og kode.

Da Fairmedia fikk en melding fra en av webhotelleverandørene om at PHP skulle oppgraderes, måtte vi gjennomgå all kode som lå inne for å dobbeltsjekke at denne faktisk ville virke i etterkant. Den største forandringen var det å gå fra <? til <?php på starten av PHP-kodene. Vi måtte da se over at alle steder vi hadde PHP-kode startet med riktig tagg.

WordPress utvikles slik at den skal støtte den nyeste versjonen av PHP og MySQL som har kommet ut på markedet og de anbefaler også at servere kjører nettopp denne. Og de oppfordrer helt enkelt de som har noen leverandører som er litt «treige» til å faktisk få oppgradert.

Noe å tenke på neste gang du føler nettsiden din kanskje går litt treigt og iallfall noe å tenke på dersom du mistenker at alle feilmeldinger knyttet til minne i loggen din kan skyldes gammel programvare.

Og forresten, hvis du lurte. PHP-versjonen til Fairmedia er 5.6.30.

Kommentarer

kommentarer